
Flash CS3 -CS101.doc  3/17/2009 

Simple Animations Using Flash 
(by Ken Abernethy, adapted for CSC101) 

 
Note: READ the intro – you should understand all terms 

1. Flash overview 
Flash is an animation program designed especially for creating animations for delivery via the Web.  
Flash uses the standard cell animation technique to create the illusion of animation.  Cell animation, 
used to create older cartoons, consists of a sequence of cells (called frames in Flash) with the scene 
changing only slightly from cell to cell.  When these cells (frames) are displayed rapidly in sequence, 
the eye is fooled into "seeing" motion.  Borrowing terminology from the hollywood, we first create key 
frames and then "fill in" between these frames.  In traditional animation, the more experienced artists 
would create the key frames and the in-between frames were drawn by "tweeners" -- apprentice artists.  
Flash (and most animation programs) use the term tweening to refer to the creation of the in-between 
frames.  These in-between frames are calculated mathematically by the software.  This takes a great part 
of the sting out of creating animations.  To produce an animation, you create only the key frames and the 
computer fills in the rest automatically. 

Flash is optimized for the Web 
Flash files are called movies. Flash creates very lean (i.e. small) movie files for Web delivery. Further, 
these movies are streamed for even more efficient Web delivery.  Streaming files for delivery over the 
Web means breaking the files up into segments so the browser can begin playing the files before all the 
file segments have been downloaded.  You're probably familiar with streaming audio (Real Audio 
popularized this technique) for music.  Flash provides the equivalent technique for animations in its 
Shockwave software.  The files Flash creates and edits have a . fla extension.  When a movie is ready 
for use on the Web, Flash "shocks" the file and produces a file with a . swf extension. You can edit the . 
fla files, but not the corresponding . swf files.  Each time you change a . fla file, you must "re-Shock" 
the corresponding . swf file to update it.  

2. Drawing in Flash 
Drawing in Flash is a odd combination of bit-mapped graphics and vector graphics. While the graphics 
objects created are always vector graphics, they behave a little differently from the vector graphics you 
may have created in drawing packages. In fact, Flash vector objects will sometimes behave as if they are 
bit-mapped graphics. This will take a little getting used to. As you'll see, the best way to avoid the 
complications that arise from this pseudo-bit-mapped behavior is to use separate Flash layers for all the 
objects we expect to animate or modify.  You can think of Flash layers as sheets of clear acetate laid one 
on top of the other, that divide a drawing into independent elements. When you are drawing on one 
layer, the other layers are unaffected. However, when the layers are all laid flat, you see a unified 
drawing and will not recognize even the presence of layers.. 
The purpose of this first activity is twofold: to begin to acquaint you with the Flash interface and to give 
you a chance to practice creating and editing Flash drawings. As we noted above, drawing in Flash has 
some peculiarities that you need to be aware of from the beginning, and we hope to get those details out 
of the way in this activity. You won't actually produce a product to save in this first activity -- it is 
purely a warm-up. In the second activity of this lesson, you'll get to apply your drawing expertise to 
create a simple animation. 
a. Open Flash (from the Adobe program group). Create a new Flash document.  If necessary, select 

File > New to get a new document. The Flash interface is configurable so what you see may not be 
exactly what is described here, but you should have no trouble finding the referred to elements.  
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b. You will see a Toolbox on the left. Along the top is a horizontal area broken into little cells called 
frames. This is the Flash timeline. The timeline can contain any number of layers, but at startup 
you'll see just one layer, named Layer 1, and it will be highlighted (meaning that it is the current 
drawing layer).  

c. The large white rectangle below the timeline is the stage. The stage is where all the action takes 
place. The stage will display the current frame. The frames are numbered 1, 2, .3, ... along the top of 
the timeline. The current frame is indicated by the red sliding indicator. Of course, it is positioned at 
frame 1 at startup. Resize your window if necessary so that the entire stage shows.  

d. Access Window > Toolbar > Controller. If the Controller option is not already selected (checked), 
select it now. You can drag this window to become part of your tool bar along the top of the main 
window if you want to (it may appear there already if the last person to use Flash placed it there). 
Notice that the buttons in the Controller window suggest play, rewind, stop, etc. These serve exactly 
these functions for playing the Flash timeline.  

e. Okay, let's practice some drawing. Select the oval tool. Find the Fill Color palette and choose red 
(Look for the paint bucket near the bottom of the tool palette). Above the Fill Color is the Stroke 
Color palette.  In the Stroke Color palette, select no color (the empty box with a diagonal red line).  
Now move to the stage, click and drag the cursor to create a red oval (holding the Shift key while 
dragging will create a perfect circle).  

f. Change the fill color and create another oval to the right of the red oval (but not overlapping it). 
Choose the Selection tool and click one of the ovals. Notice that the oval becomes shaded indicating 
that it is selected (and that it is in fact an object). Now select and drag each of the objects around the 
stage (don't overlap them yet).  

g. Click one oval and hold the Shift key down and click the other. Both will be selected and they can be 
dragged together. Click outside the two ovals to deselect them both.  

h. Now move the selection tool cursor very near the boundary of one of the ovals slowly. As you 
approach the boundary you will see the tool change shape by the addition of a small curved line at 
the base of the arrow. This modified tool can be used to change the shape of an object. Click it and 
drag to see how this works (again, don't overlap the two objects just yet). Play around with the 
reshape tool a little.  

i. Now drag one of the objects partially over the other and click outside the two objects to deselect. 
Now re-select the object you just moved and drag it back away from the other object. What 
happened? The part of the object underneath is erased. This is what we meant when we said that 
vector objects in Flash have some of characteristics of bit mapped graphics.  

j. There is a way to prevent the above behavior from occurring. If you first group an object (or objects) 
the grouped version will behave like a traditional vector graphics objects. Select one of the objects. 
With it selected, choose Modify > Group. Note the blue rectangle that now surrounds the object 
(this will appear anytime a grouped object is selected). Move the grouped object over the other 
object. Deselect it. Select it again and move it away. There should have been no impact on the 
underlying object.  

k. Group the other object (or objects -- you may have split one of the objects when you erased part of it 
above). Select the objects one after another and move them over each other. Notice that they do not 
interact at all -- except that the one that you grouped last is always in front of the other one(s). To 
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change this order, select the object that is in front and choose Modify > Arrange > Send to Back. Try 
moving it over the other object now.  

l. Select each of the objects in turn and delete them (press Backspace or Delete).  

m. Now select the oval tool and draw another oval.  

n. Choose Insert > Timeline > Layer. Notice that a new layer, named Layer 2, is created in the 
timeline. The new layer is listed at the top of the stack of layers (the higher up the layer the closer it 
is to the front of the stack of layers). Notice that it is selected (highlighted with the pencil showing to 
its right) meaning that it is the current layer.  

o. Change the fill color and draw another oval. Draw it so that it partially overlaps the existing oval. 
Select the top oval and move it. Notice that it had no impact on the oval beneath it -- this is because 
the two objects are on different layers.  

p. If we want to change the order of these objects, we must change the order of their respective layers. 
Drag (click-and-drag) Layer 1 toward the top of the stack of layers. Now notice that the oval in 
Layer 1 is in front of the oval in Layer 2.  

q. You can rename a layer by double-clicking over the layer name, pressing Backspace and typing the 
new name. Try renaming your layers according to the color of the ovals they contain -- red oval and 
blue oval or whatever colors apply to your drawing.  

r. So far, all our drawing has taken place in frame 1. Let's extend the objects to be displayed in 
additional frames. Select frame 20 in the first layer. Choose Insert > Timeline>Frame. Repeat for 
the other layer. Notice that the frames 1-20 are all grayed now and the frame indicator is at frame 20. 
Drag the frame indicator back and forth between frames 1 and 20 to see that your ovals are in each 
of these frames now.  

s. Let's change the positions of the ovals in a frame for some variety. Select the cell for the first layer 
in frame 10 and choose Insert > Timeline>Keyframe. The appropriate oval will be selected. Drag it 
to a much different position on the stage. Now drag the frame indicator between frames 1 and 20 and 
observe what happens in frame 10 (and beyond). Once a key frame is defined, an object stays in that 
position until another key frame.  

t. Use the buttons in the Controller to rewind the movie and play it. Watch the frame indicator move 
automatically as the movie plays. Notice also that you can step through the movie frame by frame 
(forward and backward) using the step buttons.  

u. Of course this isn't a very interesting movie since there is only one frame of action (from frame 9 to 
frame 10). Let's add some more action frames using Flash's automatic Tweening tool. Select any cell 
between the keyframe in frame 1 and the keyframe in frame 10. With this cell selected, chose Insert 
> Timeline>Create Motion Tween. Notice in the first layer, the small blue arrow running from cell 1 
to cell 10. This indicates that a motion tweening exists between these key frames.  

v. Rewind and play the movie again. Step through the first 10 frames using the step button. This is the 
basic principle of computerized cell animation. Define key frames and compute the 
intermediate cells automatically.  

w. Try animating the other oval. Select frame 20 in the second layer and make it a key frame. Then 
move the oval for that frame. Next select any frame in between 1 through 20 in that layer, and create 
the motion tween. Review the details above if necessary.  



  Page 4 of 7 

Flash CS3 -CS101.doc  3/17/2009 

3. Creating an animation in Flash 
The first activity explained some of the basic Flash tools and techniques and showed how the 

Flash interface is organized. You're now ready for an animation activity. We'll give less detailed 
instructions on those things that were covered in Activity 1 to give you a chance to recall the particulars.  
For a sneak peak at the movie you are going to create, use your browser to open the file 
beach_ball.html in the Animation Lab Files folder in the OUT folder. 

 

a. Create a working folder called lastname firstname animation lab.  Create a new folder in your 
working folder and name it flash1. 

b. Open Flash (if it isn't already open). Select File > New to get a new flash document.  

c. Draw a filled circle and place it in the extreme upper left corner of the stage.  Make sure the stroke 
color was set to no color. If it wasn't, set it, delete the ball, and redraw.  

d. Select the pencil tool and draw a line segment across the center of the circle (approximately -- 
doesn't have to be precise). Make sure you draw the line from one boundary of the circle to the other 
(no gaps at the two ends of the line segment). Repeat to draw a line segment splitting the circle 
vertically as well. Your circle should be divided into four more or less equal slices.  

e. Select a color different from your circle (one of the bright colors of the palette). Use the paint bucket 
to fill one of the slices on your circle. Repeat with different colors for two of the other three slices. 
Your circle should now resemble a beach ball.  

f. Click in frame 15 and insert a keyframe.  With frame 15 selected, move the ball to the middle- 
bottom of the stage (just touching the bottom edge of the stage - it will bounce back up and to the 
right).  

g. Select any cell between 1 and 15 and apply the Motion Tweening. Test your work.  

h. Select frame 15 again and select the ball (it should be at the bottom center stage). With the ball 
selected, choose Modify > Transform > Rotate 90° CW. Test your movie again.  

i. Repeat the previous three steps -- this time extending the motion to the upper right corner of the 
stage in frame 30. Rotate the ball to the clockwise again. Test the completed movie when you finish.  

j. Save the movie as beach_ball.fla in your folder.  

k. To save it as a useable movie, select File > Export>Export Movie and choose your preferred format 
(Save as Type: select any of the choices: Shockwave .swf; GIF, PNG, etc.) 

4. Motion animation in Flash 
Recall that to create an animation, you first create key frames and then let Flash "fill in" between these 
frames. These in-between frames are calculated mathematically by the software. There are actually two 
different kinds of Flash tweening techniques as these are called: motion tweening and shape tweening. 
Both kinds of tweening are applied to all frames between two key frames. Of course, you can have as 
many key frames as is necessary in a complex animation, but separate tweening computations are 
performed between each successive pair of key frames.  
Motion tweening computes intermediate positions for an object that is in two different positions in the 
two enclosing key frames (it can also be used to create intermediate colors for an object that changes 
color between key frames -- whether or not it moves). Shape tweening computes intermediate shapes 
for an object that changes shape (and perhaps position as well) between enclosing key frames. These 
techniques take a great part of the sting out of creating animations. To produce an animation, you create 
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only the key frames and the computer fills in the rest automatically. We now focus on motion tweening 
and take up shape tweening later. 

 
Preview the movie you’re about to create: find  balloons.html among the files we have provided. 

a. Create a new folder inside your working folder and name it flash2. 

b. Open Flash (if it isn't already open). Select File > New to get a new Flash document.  

c. We'll first draw the background for the movie.  Use the properties panel (below the stage) to change 
the default background color to a "sky blue" color. 

d. Next, make sure the stroke color is empty and select a fill color of green for the grassy area at the 
bottom of the background. Draw a filled rectangle that covers the lower third or so of the stage.  

e. Select a purple color for the mountains. Select the brush tool and set the brush size fairly small. 
Draw the mountain ridge outline from one side of the stage to the other. Make sure the two edges 
come down to the grass – with no gaps.  Now use the paint bucket to fill the mountain area with the 
same purple color.  

f. Rename Layer 1 to "background" and click the padlock dot (under the padlock icon) to lock the 
background layer. This will prevent any inadvertent changes being made to it. Now, insert another 
layer (Insert > Timeline>Layer). Name this layer balloons. Save your file as balloons.fla in your 
flash2 folder.  

g. Use the oval tool to make a balloon cluster. Use bright colors as in the example. Use the line tool to 
draw the balloon strings. Drag the selection tool to enclose all the balloons and strings, then choose 
Modify > Group. Move the group to the left of the stage at about mountain level as a starting point 
(consult the example if necessary).  

h. Select the background layer's frame 75 and choose Insert > Frame. This extends the background 
existence for 75 frames. For the balloon layer, go to frame 75 but choose Insert > Keyframe instead. 
With balloon's frame 75 selected, move the balloons to the upper right corner of the stage. 

i. Select a balloons layer frame anywhere between frames 1 and 75. Choose Insert > Timeline>Create 
Motion Tween. Test the movie by playing it. Save your file.  

j. Lock the balloons layer.  Insert a new layer and name it up_away. Select frame 15 in this layer and 
insert a keyframe.  

k. Select the text tool. Click the text tool over the balloon group on the stage. Type "UP" in the text 
box. Adjust the color and size of the text to make it a dark blue and the size so that it large but still 
within the outline of the balloons. Move the text to center it on the balloon cluster.  

l. Select frame 30 in the up_away layer, insert a keyframe, and add another text object also showing 
the text "UP" over the balloon cluster in its new position in frame 30. 

m. Select frame 45 in the up_away layer, insert a keyframe, and add more text that reads "AND". You 
may have to reduce the font size a bit to keep this within the balloon cluster borders.  

n. Select frame 60 in the up_away layer, insert a keyframe, and add the final piece of text: "AWAY". 
Again, you may have to reduce the font size a bit to keep this within the balloon cluster borders. You 
should have 4 separate pieces of text saying "Up Up and Away". Save your file. Test your movie.  
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o. Actually, we want the text to emerge from behind the balloons. (We inserted it in front to make it 
easier to position with regards to the balloon cluster boundaries). Now, drag the balloon layer to the 
top of the layer stack and play the movie again.  

p. To complete the movie we need to add the Welcome to Flash!! text. Insert a new layer and name it 
welcome.  

q. Select frame 15 in the welcome layer and insert a keyframe. Select the text tool and type 
"WELCOME TO yourname's FLASH!!". (Where yourname is your full name).  Put this in "Arial 
Black" font and increase the font size to about 28. Make the text the same color of purple as the 
mountains. Move the text box just off the stage at the bottom-middle.  

r. Select frame 60 in the welcome layer and insert a keyframe. Move the text box holding the welcome 
message to its final position – middle of the grass. 

s. Select a welcome layer frame anywhere between frames 15 and 60.  Create the Motion Tween. Test 
the movie by playing it. Save your file.  

t. The last step is to keep the welcome message on the screen until the end of the movie. Select the 
welcome layer cell in frame 75 and choose Insert > Timeline>Frame to do this. Test again. Compare 
to original movie. Save your file.  

5. Shape animation in Flash 
Shape tweening works in a very similar way to motion tweening. The difference is that in the key frames 
you will distort or change the shape of the object you're animating. The automatic shape tweening 
algorithm in Flash will then calculate intermediate shapes to create a meaningful animation. Irregular 
shapes can produce some surprises, but a little experimentation will produce good results using shape 
tweening. You'll see how this works next. 
 
 Please preview the movie you are going to create by opening balloons2.html. 
a. Create a new folder and name it flash3 inside your working folder. 

b. Open Flash (if it isn't already open). Select File > Open to open the movie balloons.fla that you 
created earlier. This file should be in your flash2 folder.  

c. Choose File > Save As and save this movie as balloons2.fla into your new flash3 folder.  

d. We'll add the clouds to the movie in this activity. Notice that the clouds drift with different speeds 
and that the balloons are behind some of the clouds and in front of others. We'll accomplish this with 
two new layers each holding a cloud set.  

e. Insert a new layer.  Name this layer clouds_front. Click the 
padlock to lock all the other layers. Roughly, the clouds in 
the first frame of this layer should look like this: 
Of course, your clouds won't look exactly like these -- nor 
is that important at all. Just try to approximate this 
drawing. Use the brush tool. Choose an oval brush shape 
and a medium size brush size. 

f. Select the clouds_front layer cell in frame 75 and insert a 
keyframe. With frame 75 selected, move the entire 
selected cloud group toward the right edge of the stage so 
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that the rightmost cloud is partially off the stage. Deselect and use the selection tool to reshape each 
of the clouds as well (remember, if you grab the edge of the objects you can reshape them). Here's 
what our cell in frame 75 looks like. Try to approximate this, but of course anything close will do 
just fine. 

g. Click over any cell in the clouds_front layer between frames 1 and 75.  Use the Properties panel to 
select Shape Tweening.  Play the movie to make sure everything works the way you intended. Lock 
the clouds_front layer and save your file.  

h. Insert a new layer.  Name this layer clouds_distant. 
Here's what the clouds in the first frame of this layer 
should look like. Note that we have hidden the 
clouds_front layer (click the eye icon) to make this 
layer easier to see and work with. 

Of course, your clouds won't look exactly like these. 
Try to approximate this drawing. Again use the brush tool. Choose an oval brush shape a smaller 
brush size. 

i. Select the clouds_distant layer cell in frame 75 and insert a keyframe. With frame 75 selected, move 
the entire selected cloud group toward the right 
edge of the stage so that the rightmost clouds are 
partially off the stage (see figure below). 
Deselect and use the selection tool to reshape 
each of the clouds as well (remember, if you 
grab the edge of the objects you can reshape 
them). Here's what our cell in frame 75 looks 
like. Try to approximate this, but of course anything close will do just fine. 

j. Now, repeat the Shape Tweening steps in the clouds_distant layer between frames 1 and 75. Lock 
the clouds_distant layer. Move this layer down the layer stack to just above the background layer. 
This will put the clouds on this layer behind everything else except the background.  

k. Use the eye icon to “un-hide” any hidden layers and then play the movie to make sure everything 
works the way you intended. Compare to the original movie. Save your file.  

Shock this file (Export it as a .swf file) and use Dreamweaver to place it on a 
new web page called webballoons.html – Save it in the flash3 folder. 

l. Consult the class web site to make sure you have everything required in the lastname firstname 
animation lab folder, then copy it to the IN folder on the server. 

6. Conclusion 
We wish to emphasize that this activity in no way exhausts the possibilities of Flash.  Be sure to check 
out the web for workshops, tutorials, and Flash help and examples that will keep you busy for a while! 


