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The remote server information that we just ignored has to do with where your site will be stored on a 
Web server.  As this suggests, Dreamweaver provides a facility for uploading your Web sites to the 
Web.  However, we will instead be using a different method for uploading files. 

Click Done on the summary page.  You should see the “Files” panel on the right. This window is a 
useful tool that you can use to keep track of the files in your Web site.  It can also be used to change 
between multiple Web sites – if you are maintaining more than one. 

NOTE: When started, Dreamweaver automatically uses the last site used.  This works well for personal machines 
but does not work for a shared lab environment where the last site used may be someone else's.  Always remember to 
re-define your site to the proper location each time you use Dreamweaver in our lab. 

Seeing the HTML 

h. To start editing a new file, use the File>New menu option, then choose HTML and click Create.  A 
blank document is shown.  Take a moment to survey the icons and tabs in the various locations that 
you see (“Common”, “Layout”, “Properties” etc.).  Move the cursor 
over different buttons that you see to get their names.  You’ll recognize 
many of the controls (particularly in the Properties window) from word 
processing, and you may have a good intuition about others from the 
HTML reading. 

i. Before typing anything into your web page, find and click on the 
“Code” view button on the left side of the new document’s toolbar.  
This button will show you the HTML code that underlies your Web 
page.  Currently, HTML code similar to this box should appear on the 
page. 

Periodically throughout this activity you might want to take a "sneak peek" at the developing HTML 
code.  Though we will primarily be using the WYSIWYG feature of Dreamweaver to create our pages, 
keep in mind that the editor can also be used to edit the "raw" HTML.   

j. Click on the Design view button to return to the WYSIWYG view. 

Page titles 

 The title of a web page is the information that appears in the title bar of the browser when the page 
is being viewed.  It is also what appears in any Bookmarks lists.  Note that a title doesn’t appear as 
content on the page itself. Currently this document title should be “Untitled Document”. 

h. To give the page a title, click in the document toolbar where it says Title: “Untitled Document”.  
Type a temporary name like Behold my new title! in the box.  Again, click on the Code view button to 
see what has happened.  Notice the title tags and your text. While still in code view, change the title 
text to something like “Jane Doe’s Home Page”-only use your name.  Click on the Design view 
button.  

i. Execute File>Save to save the page.  Make sure the file is saved in your local root folder.  Use the 
filename index.html for reasons that will be explained later.  Look at the Files panel to see your 
new file. 

2. Formatting the page and adding content 
a. Enter your name, school year (junior, senior, etc.) and contact information (expected major 

department and e-mail address) on separate lines.  

Note the wide spacing between the lines of your information.  This spacing is because the “Return” key places 
paragraph tags (<P>) into your document.  A paragraph tag takes you to a new line and inserts a blank line.  
Preferable in some cases is a line break tag (<BR>).  Delete just your department and email information and retype 
them using a Line Break at the end of each line (Get a ‘break’ by pressing the Shift and Return at the end of a 
line)  Just remember – text separated by line breaks are treated as one paragraph! 

<!DOCTYPE HTML PUBLIC 
<head> 
<title>Untitled Documen 
<meta http-equiv="Conte 
</head> 
 
<body> 
 
</body> 
</html> 
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The Properties Window

Next, we will add formatting to your personal information.  Here is how it’s done in Dreamweaver: 

b. Position the cursor by clicking anywhere on your name.  Then go to the Properties panel, Format 
pull-down menu (which currently is labeled either 
None or Paragraph).  Choose the option Heading 1.  
Then do the same with your class year. 

c. View the HTML again.  Your name and class year should be surrounded with respective 
<H1>...</H1> tags, like so: 

  <H1>Jane Doe</H1> 
  <H1>Senior</H1> 

d. Next, type the words "Contact Information" on a new line above your major information -- and make 
it into a Heading 2 format.  Try making your email address a Header 6 format. 

3. Adding pages to your site 
Virtually all Web sites consist of multiple interlinking pages.  Adding new pages using Dreamweaver is 
straightforward.  In this section we’ll add a new page with some of your favorite links. 

a. Save and close the current page (this is your home page).   

b. Execute the command File>New    Choose HTML and click Create.  This will give you a new blank 
page.  Save the file immediately using the filename links.html.  Note that the file should 
appear in your site’s root folder.  (See the Files pane on the right) 

c. Enter the text:  Links to some other stuff 

d. Save this file 

Now we’re ready to start putting these pages together into an interlinked site. 

4. Adding links to other documents 
What makes HTML particularly special is the ability to include hypertext links in the Web pages it 
produces.  Hypertext is the special words (or images) on a page that can take you somewhere else on the 
same computer—or halfway around the world—with a single click. 

Implementing hypertext links is very simple in HTML.  They employ tags like those we have already 
seen.  The general format of a link is: 
  <A HREF="resource URL">text or image</A> 

It's that easy!  The A stands for "anchor", and HREF stands for "hypertext reference".  URL stands for 
"Universal Resource Locator". 

A basic familiarity with URLs is assumed, but as review, a URL such as this example: 
  http://cs.furman.edu/students/acmw/about.htm 

breaks down as follows: 

 http:// — identifies the resource to be accessed as a hypertext page from another web site 
 cs.furman.edu/ — identifies the server address on the Internet 
 students/acmw/ — identifies the directory path to the resource 
 about.htm — identified the file name of the resource 

There can be numerous variations of URLs.  The resource identifier may be other things besides "http" 
for instance.  Sometimes the path may be omitted, as well as the file name.  This is because certain paths 
and file names are accepted as defaults by Web browsers.  (index.html is a default name, as you may 
have guessed.) 

It is important at this point to note that URLs come in two forms: absolute and relative.  The easier of 
the two to understand is the absolute form.  In short, an absolute URL is one that is fully specified, 
including http:// and the server address.  The example above is an absolute URL. 
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Specification of URLs in HTML code can sometimes be simplified by using the relative form.  This is 
possible whenever a link is to another resource on the same computer .  In short, the resource identifier 
and machine address can be omitted in this case.  As long as a browser can determine where a resource 
is—based on where you currently "are"— a URL can be relative.   

Rule of thumb: use relative URLs when you are creating links to pages of your own, and use 
absolute URLs when you are creating links to pages elsewhere on the Web. 

Adding links: Relative URLs 

Let’s link together the pages of your site now.  As the previous analysis suggests, we’ll use relative 
URLs to do it.   

a. Open your home page (index.html).  [An easy way to do this is to use the “Files” listed by selecting 
from the Files panel on the right. Your current site (“Bobs Demo Web”) should be shown.  You’ll see a 
convenient listing of all files and folders in the local root directory.  Double-click the file index.html that 
you created earlier.] 

b. Below your email address, we will add links to two other pages  (links.html and action.htm)  Start by 
positioning the cursor appropriately and entering these phrases  “Other Links” and “Things to do” on 
separate lines. 

c. To make the words "Other Links" into a hypertext link to your links.html page, Select that text with 
the mouse and then enter the URL of your links.html page in the “Link” box of the Properties window.  
Since this page is stored in the same folder as the home page, all you need is the relative URL — 
links.html.  Instead of typing the filename, however, click on the folder icon to browse for the 
file.  When you have confirmed the file selection, click OK. 

d. To test the link, you’ll need to view your page in a browser like Firefox or Internet Explorer.  Save 
your file, then choose File>Preview in Browser and select the browser of your choice.  When the 
browser opens, click on the “Other Links” text.  Did it do what you expected?  Close your browser. 

e. Repeat the same process in order to make “Things to do” into a link to the action page found in the 
images folder. 

f. Finally, open the links.html.  Add the text “Return to Home Page” and make it a hyperlink back 
to index.html. 

Open the file action.htm and look closely at the format of the link back to index.html.  Notice how the 
relative path specifies to go “up” in the hierarchy.  This is important to remember. 

External Links (Absolute URLs) 

You have now linked together the various pages of your demo site.  But this is most interesting when we 
are able to link to sites other than our own: 

g. Open your “links” page and insert the following text (before the “Return to Home Page” hyperlink)  

using the Header 2 format:  My Links 
as regular text:   Sports Site 

h. Now, make the words "Sports Site" into a hypertext link.  As you did before, select the text and then 
use the “Link” box of the Properties window to type  

  http://sportsillustrated.cnn.com 

 Hit the Enter key.  In your file the "Sports Site" text should now be a link.   

i. Test the link by previewing the page in a browser. 

j. In Dreamweaver, click the Code view of the links.html page.  You should see the following code: 
  <A HREF="http://sportsillustrated.cnn.com">Sports Site</A> 
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k. Find and make note of 2 or 3 URLs other favorite external pages 
and add new links to your links page.  Be sure to separate the 
items with paragraph breaks. Confirm each link by previewing in 
a browser. 

The e-mail link 

A popular web page feature is to have a link that allows someone to 
quickly and easily send e-mail to the author of a particular page.  
Make your e-mail address into one of these. 

m. Highlight your e-mail address on your home page.  In the “Link” field of the Properties window, 
enter the following: 

  mailto:first.last@furman.edu 

 using your own e-mail address (of course!).  Confirm 
that there are no spaces; then hit the Enter key. 

 

Note that you can also create a new e-mail link easily using 
Dreamweaver and the Insert E-mail Link button in the toolbar. 

5. A bit more HTML 
Before moving on, let’s apply a bit more polish using additional features of HTML. 

Horizontal rule tag <HR> 

You have already seen how to separate the different segments of your page using paragraph heading 
sizes.  Often a non-text separator is desirable.  It is for just this purpose that HTML includes a 
facility for including horizontal lines as dividers.  These are implemented using the <HR> 
(“horizontal rule”) tag. 

a. As a learning experience, we will add this tag by typing directly in the HTML.  Return to the index 
page and click Code View.  Move your cursor to before the “Contact Information” header tag.  Type 
the <HR> tag.  View in WYSIWYG (design view); if a horizontal line did not appear, recheck your 
tag. 

Lists 

Web page information is often organized into lists.  HTML provides tags for the implementation of 
three major types of lists: unordered (bullets), ordered (numbered) and definition lists.  We’ll 
implement the first two today, and leave the third to your own exploration. 

b. Open your links page and convert your list of links to an unordered list: First highlight all the links 
that you created earlier.  Then click the Unordered List button in the Properties window (that’s the one 
with the bullets). 

 You can also create lists simply by typing them while the Unordered List button is clicked.  To end the 
list, hit the “Enter” key twice consecutively, or re-click the Unordered List button. 

c. Take a look at the HTML code - you should recognize the HTML tags that handle the list items. 
(<ul> for unordered list; <li> for list item; <ol> would be the tag for ordered list) 

Character formatting 

 Centering text and formatting characters (bold, italics, etc.) is as easy in Dreamweaver as it is in a 
word processor.  You should experiment with some of these options (in the Properties window). 

 

Links 
When creating links to existing Web 
pages, Copy and Paste can be valuable 
aids.  When you find a page that you 
want to link to, highlight the URL in 
the browser window and select Copy 
from the Edit menu.  Then return to 
the Properties window of 
Dreamweaver and Paste the URL. 

CS LAB NOTE: The email link may not 
actually allow you to send mail in this shared 
lab environment, but it should fail gracefully – it 
should work fine from a personal machine with 
mail properly set up 
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6. Using images 
Let's add a picture to the beginning of your home page, just before 
your name.  Images that are interspersed with your text are called 
in-line images.  A special tag, called IMG, is used to include 
these.  This tag uses the following basic format: 

  <IMG SRC="URL for image"> 

 The first thing you will need, of course, is a digitized image of 
some kind.  A scanner, digital camera or drawing or painting 
software could be used to create original images.  Also, any image 
that you find displayed on the Web can be downloaded to your 
disk and re-used (with permission, if necessary).  To see how it's 
done, let's get a picture of some Furman scenery. 

a. First, use a web browser to access 
http://www.furman.edu/postcard/   Select a Furman scene by 
clicking on it.  To save your own copy, simply right-click on the image.  A menu will pop up on the 
screen.  Select Save Image As (or Save Picture As ).  You will then be presented with a dialog box 
asking you where to save the file.  Save the image file into your “Demo” web site that you’ve been 
working in.  Don’t change the file name, but make a mental note of what it is. 

b. Return to Dreamweaver and open your index page. Position the cursor before your name and hit the 
Enter key, then reposition the cursor above your name.  Click on the toolbar’s Image button—
identified by a small drawing of a tree (or use the menu: Insert>Image).  Navigate within your site 
folder and select the image that you just downloaded. Click OK.  (You may ignore any other dialog 
options if shown) The image should appear on your page. 

c. Note the little black squares around the image.  Use these to resize the image, as needed, by clicking 
and dragging.  Resize the image to the size of a business card (about 2 inches?).  Now, save your 
home page. 

d. Return to the site “File” listing.  Now we’ll illustrate another nice feature of Dreamweaver.  Note 
that your Furman image is stored with all of your other files.  It is better idea to organize all images 
for your site in a common location, such as the “images” folder I created for you.  Within 
Dreamweaver, reorganizing is easy, from the Files panel simply drag the file icon for the image that 
you downloaded onto the “images” folder and release.  (When Dreamweaver asks you to “update 
files”, answer yes, by clicking “Update”)   
Ordinarily, at this point you may not expect the image to show up on your home page anymore, 
because the image file location has been moved.  However, Dreamweaver has updated the URLs of 
all files that need to link to the image.  To see this, return to your home page and click the Code 
View button.  Find the <IMG> tag and note that the “images” folder name is now part of the relative 
URL for the image.  [Note: You may also use this tool to rename a file and Dreamweaver will 
change all references to it] 

e. As mentioned earlier, hypertext links need not always be text.  We can make the Furman image into 
a link to the Furman home page simply by treating the image as we have previously treated text 
links. 

Make sure that you are in the WYSIWYG design view -- click once on the image to highlight it.  Then 
enter the Furman URL in the “Link” field of the Properties window (absolute URL please!).  Save 
these changes and then preview/test the page. 

Note:  If you choose an image 
that is on your disk but not in 
your local site root folder, you 
will be given the opportunity to 
make a copy of the image 
somewhere in the root folder.  
You should make a copy.  If you 
don’t, everything will work fine 
for now, but the image will be 
“broken” when you upload your 
site to a Web server, because the 
server won’t know where it is. 
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Replace your background color 

f. To apply a colored background to a page, simply select Page Properties from the Modify menu.  
Find the Background color and click the Color Selection box to select an appropriately light color.  
(Note that Link colors and other page properties could also be modified here.) 

7. Miscellany- additional notes regarding Web authoring with Dreamweaver 

Returning to work on your site 

When you come back to edit your site again, you must begin by “defining your site”.  This is what you 
did at the beginning of this lab (steps 1c-1g). 
 

Note: When you are defining or editing your site, you may see a list of other defined sites.  These might 
remain from other students using this computer in other classes.  To be safe in the lab, always define a 
new site.  Always make sure your site is defined to your folder and not someone else’s. 

Importing information 

If you have previously created HTML pages using other tools (e.g., raw HTML, Microsoft Office, 
another Web editor, etc.) it is no problem to import them into Dreamweaver.  Simply copy the needed 
files into your local root directory and open them as you would one of the files from your site created by 
Dreamweaver.  Since HTML is machine-independent (works the same on all computers), Dreamweaver 
will interpret the HTML correctly, no matter how complicated. 

Final Tasks 

We’ve covered the basics, in the next few weeks we will cover some fancier things.   
 

 SAVE ALL RELEVANT FILES ONTO YOUR PERSONAL BACKUP AREA (Fushare, USB 
DISK, et al) 

 CONFIRM THAT ALL FILES ARE PROPERLY SAVED 
 

Saving Your Data on the G-Drive (fushare) 

If you have a fushare account (G drive on your personal campus computer), please use it for all 
your work for security, privacy, and convenience.  If you need an account call the help desk 
@3277 

You can access this from anywhere on campus by doing the following: 

1. Click on the Start Menu and select Run 
2. In the dialog window, type  \\fushare\username 

where username is your account name.  Press Enter. 

3. When the Login box comes up, in the Connect As box, type FU\username  
              and type your password in the Password box. Press Enter. 
4. A window should appear that has your fushare files. 
 
 

SUMMARY 
Basic concepts you should have learned: 
 Using Dreamweaver "Sites" 
 HTML tags 
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 Formatting a page (content and title) 
 Changing an existing web site 
 Making Hypertext links (absolute and relative) 
 Inserting images 
 Making new pages 

What you should have completed: 
 Two new web pages (index.html and links.html) as described in the text. 
 Working (tested!) text links between the site pages 
 Working link to www.furman.edu from the resized Furman image 
 index.html page changed background color 
 Text formatted as described in the text 

 

HOMEWORK: (Due next Monday - noon) 
Put web page onto the Furman student web server for the whole world to see 

 Access your fushare network disk (see instructions above).  Create a new folder 
called public_html  This folder will contain your entire web site. 

 Open the public_html folder and drag and drop your files: 

 You should copy the entire contents of the Demo 
site folder but NOT the folder itself.  That is, the 
HTML files and the images folder must be located 
directly in the public_html folder (not within 
another folder).   

 Folders created and used only by Dreamweaver (such as: 
Library, _notes, Templates, etc.) are not required on the 
web server.  It will not hurt anything if you copy them too. 

 Confirm that your web page works using a browser to view the URL 

students.furman.edu/~youraccount 

 In order to link each student in the class to the “next” student, give your complete and 
working URL to the student before you on the class roster.  Each student will take the 
URL of the “next” student and make a link:  add the image next.png to your home page 
(just below the Furman picture) and make it link to their home page. 

Note: Your Next link should show the “next” student's page – if not, both of you should work 
together to fix the problem.  Most common problems: 1) link shows a valid, empty folder (Cause: 

No files in public_html folder) 2) Link shows "Not Found" (Cause: link is a bad URL) 

links.html 

action.htm 

public_html 

images 

next.png 

index.html 


