
 

Exploring Additional Authoring Techniques in Dreamweaver 
DW-II Lab 

Overview: Having completed an overview of the Dreamweaver basics, we now turn our attention to 
some additional features that you are likely to use frequently.  We will consider 
formatting web pages using tables and also learn about image rollovers, imagemaps, and 
other active page elements. 

Before beginning:  Dreamweaver requires you to organize your site inside your local root folder (that you created last lab).  You 
must let Dreamweaver know where your site is located (You need to choose “New Site” in the Site menu)  

Open Dreamweaver and choose Site>New Site.  Name the site as you like; and answer the various 
questions (ie Select “No server technology”; “None” for LAN option; etc)  You MUST choose your site 
folder as the site’s Local Root Folder.  Remember to properly set your site each time you use 
Dreamweaver! 

1. Tables in Dreamweaver 

Tables are used in web pages to provide formatting options that are not available using other HTML 
tags.  For example, placing information side-by-side is somewhat difficult without tables.  Tables can be 
used for mixing images beside text or creating ‘columns’ as well as other formatting needs. 

1a. From the desktop of Windows, find the class OUT folder and copy the contents of the folder labeled 
DWII Files to the same folder that your files from the first Dreamweaver lab are in (Bob’s 
Demonstration or something similar).  Images should go in your images folder. 

1b. Use Dreamweaver to create a new html file: File menu > New option;  Select “Blank Page” and then 
“HTML”. Click Create.  Give your blank page a title (like “Monthly Activities”) and text (formatted as 
a header 1) like “Coming Events” and then save this file as calendar.html 

The method used for creating tables is really quite simple.  Let’s create a table representing a simple 
calendar for this month: 

1c. Position the cursor below the “coming Events” and select Table from the Insert menu.  We’ll need 
seven rows – one for the month name, one for the day names, and five for the dates of the month.  
We’ll need seven columns as well.  Set the table Border thickness to 2.  Enter these figures and then 
click OK.  A blank table will appear on your page. 

Filling in the data is remarkably easy.  Just think of each table cell as a distinct Web page.  Anything 
you want to put in there you can. 

1d. Click in the first cell on the second row.  Type in Sunday, center it and make it bold.  Then increase 
the point size.  (Choose 14 pt in the Size box in the “Properties” window.)  Enter and format the rest 
of the names of the days of the week across this row. 

1e. Enter the numerical dates of the month.  Jan 1st was a Thursday. 

1f. Presumably you’d like to center all of the days and dates, but you’d rather not have to click on each 
one individually.  Fortunately, there is a shortcut.  To center all of the data, first highlight all the 
cells in the table by clicking and dragging the mouse from the upper left hand cell to the lower right 
hand cell.  Then click on the center align button in the Properties window.  That’s all. 

Non-standard table structure 

 In our example, we still have to add a month name.  We could stick it in the middle cell of the first 
row, but as we’ve seen, that could cause the whole middle column to expand and look awkward.  What 
we’d rather do is modify the first row so that it contains only one cell spanning all seven columns. 



 

1g. Do this by first selecting the entire first row of the table with the mouse.  Then look in the bottom 
half of the Properties panel.  (You may need to click on the downward-pointing triangle arrow in the 
lower-right corner.)  Click, the Merge Cells button (immediately below the word “Row” in the 
Properties panel).  Note the effect.  The first cell now spans 7 columns as requested.   

1h. Enter the current month and year in the cell, center it and make it a level one header. 

Tidying up 

There are many additional formatting features of tables that allow you to design them to your tastes.  
For instance, tables can be centered on the page.  In addition, you can choose specific widths and 
heights for rows and columns, respectively, set the width of the table border, specify the space between 
cells, and the space which surrounds the cell contents.  You can also change the colors. 

To do any of these things, you’ll first have to select the table, which you can do by moving the cursor 
over any corner of the table, until it turns into a small table icon.  Click to highlight the entire table.  
Then look in the Properties window for things you can change.   

1i. Change the width of the table to 90%. (i.e. 90% of the width of the browser – the actual width will 
depend on the size of whatever browser opens this page) Preview this change – test the 90% table 
by changing the browser window size. 

1j. Center the table on the page using the Align option.(Make sure you select the entire table!) 

1k. Experiment with the “Border”, “CellPad” and “CellSpace” options to see what they do. What is a 
border of 0?  Finally, set the border to 3, spacing to 3 and padding to 8.   

1l. Experiment with setting different background colors for the table (Bg color), and for the border  
(Brdr color) before setting the background color to pale green and the border color to hexadecimal 
RGB values: #003300. 

1m.You can also change the properties of individual cells.  Place your cursor in a (any) special date (or 
make-up a holiday) and give it a dark blue background with white text. 

1n. Save the page and preview it.  Resize your browser window and notice how the formatting changes 
automatically based on browser (client) attributes. 

1o. Return to Dreamweaver.  For practice, select two side-by-side cells and merge them 
1p. As a further example, select two vertically adjacent cells and merge them.  Hopefully you get the 

idea of the flexibility of tables.  

2. Web layout design using tables  

The data that is displayed in the cells of a table need not be just numbers and/or 
text.  Images can be incorporated, as can links and even other tables.  Tables 
have become a very effective tool for the creative design of Web pages.  
Consider the Furman University home page (www.furman.edu).  This page 
actually uses a number of tables, including tables-within-tables.   

2a Try this simple exercise: create a new page and add a  2-row, 2-Column table.  Save this file as 
layout.html. Type some H1 header text in the upper left-hand corner.  Place the dog.jpg image in 
the lower left-hand corner.  Add an unordered list in the lower right hand corner.  

2b Change the table's border to zero.  Shrink the size of the images and table so that it all fits neatly on 
in about half the window. 

2c In the upper right cell, insert a 3-row, 2-column table.  Add a word or two in each of the rows in the 
first column.  Now, merge the entire second column into one cell and add the test.gif image to that 
cell.  Make sure the total size is still about ½ page 

2d Finally, at the bottom of this page, add a text link to your calendar.html page before saving. 
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3. CSS Styles 

Many times we need a way to quickly create a common “look” to them.  One way to do that is to define 
what are called cascading style sheets (CSS).  Such a style sheet can specify, for instance, that all level 
1 headers should be yellow text on a black background.  It can also specify that all lists should be 
italicized and use the Arial font. A style sheet can apply to a single page, or to an entire site.  

In addition to defining styles for existing HTML features, you can design your own styles with specific 
names and apply them wherever you wish – to a word, a paragraph, a whole page, etc.  (This is just like 
the ability to define your own styles in Microsoft Word.) 

Defining styles for a single page 

To specify how you want different things to look on a specific page, you use what is called an inline 
style sheet. (This style will affect one page only). 

3a. Open the file stylesheet_test.htm. 

3b Select the entire first-line level 1 header.  Go to the Text menu and select CSS Styles then New… 

3c. In the dialog box, choose the Selector Type as “Tag(redefines the look of a specific tag)”; the Tag is 
"h1";  and the Define in should be:  “This Document Only”.  You have just indicated that you are 
going to change what the <h1> tag means for only this page.  Click OK. 

3d. A new window will come up called “CSS Rule definition for h1”.  Explore your options here: you 
can really go to town here!  For this lab choose:  font as “Arial, Helvetica, sans-serif”.  For color, 
choose red.  In the Category list, select “Background”.  Choose black for the background color.  
Click OK.   Isn't red on black hideous!?! 

Could you have predicted what would happen?  Did it surprise you that two of the headers changed?  
Again, you have redefined the level 1 header for this entire page, so all of them will change.   

3e. If you need further proof, click on one of the level 3 headers and change it to level 1.  Use 
Edit>Undo to change it back to level 3 again. 

3f. Click on the word “Finally” in the bullet list.  Repeat the previous steps to make all list items 
(HTML tag li) change to italic and blue.  (Italics is a change to the style) 

Defining styles for an entire site 

What we just did was pretty powerful.  But style sheets pack even more of a punch when they are used 
to define styles for an entire site.  This uses what are called linked style sheets.  In this case, you have 
one style sheet stored in a separate file that all pages of your site include.  A huge benefit is that you 
can change your style definitions in one place and they’ll be changed throughout your site. 

Dreamweaver makes this easy as well.  First, though, we need to get rid of the inline stylesheet that you 
just created. 

3g With stylesheet_test.htm open, click on Code View button on the toolbar.  Scroll to the head section 
of the document and you’ll see an HTML tag that looks like this: 

  <style type="text/css"> 

 This tag is the style definition.  Highlight everything from this line down to </style> and delete it 
(about 10-13 lines).  Click on the Design View button.  Note that the changes you made previously 
are now gone. 

3h Reselect the H1 first line:  Go to Text>CSS Styles > New again, and confirm "h1" tag but this time 
choose Define in "New Style Sheet File”. 



 

3i This time when you click OK, you’ll be asked where to store your linked stylesheet file.  Call it 
mystyles.css and store it somewhere in your folder.  Once you’ve done this, you’ll be returned to the 
“Style definition for h1” window, where you can redefine <h1> (or any other tag) as you like – 
make if different.  When you are finished, you’ll see the styles changed. 

The key thing to understand here is that anything that you define in this file will affect all pages that use it! 

3j Now open the layout.html page.  Go to Text>CSS Styles>Attach Style Sheet.  Select Link (not 
Import).  Click the Browse button and find the mystyles.css file that you just made.  Click OK 

Voila!  The styles have now been applied to your new page.  More importantly, you can easily repeat 
this single step for every page in your site.  And when you want to change how your entire site looks, 
you simply change the style sheet and the changes take effect throughout your site. 

3k One more change – we will make a change to the mystyles.css style H1 tag to use yellow on black.  
Note the CSS panel in the upper-right of Dreamweaver – open this, select mystyles.css and double-
click h1.  Make the appropriate changes and then save and preview your pages. 

Creating customized styles 

There is one more way to use style sheets before we leave the subject.  You can define your own named 
styles in Dreamweaver.  The idea here is that you define how you want something to look, give it a 
name, and then apply that style by name where and when you want.  It’s pretty easy to do. 

3l. Open up your stylesheet_test.htm page again, if it’s not already open.  Once again, go to Text>CSS 
Styles > New 

3m. But this time select “Class (can apply to any tag)”.  For the “Name” of the style, enter “bigandgreen”.  
Confirm: "Define in mystyles.css" and then click OK.  Next you’ll see the style definition window that 
you’ve seen before.  Now you’re going to define what “bigandgreen” means. 

3n. For “Size” choose “x-large”.  Then pick green for the color.  Click OK.   

3o. Back on your Web page, click anywhere in the “Isn’t this fun?” paragraph.  We now want to apply 
the big&green style to this text.  Your custom style is available under the Text menu > CSS Styles 
You will see that “bigandgreen” is one of your options.  Just click on it once.   

3p. Choose Edit>Undo to reset the text to the way it was.  Now highlight just the word “plain”.  Again, 
choose the “bigandgreen” style.  Is this making sense?   

Experiment for a while with other options available and save & close these files. 

5. Fun with Images – Imagemaps 

A topic that we have not yet discussed is that of creating imagemaps.  An imagemap is an image that 
contains “hot spots” – regions of the image which can be clicked –on to link to some other Web URL.  
With Dreamweaver’s imagemap editor, creating imagemaps is easy. 

5a. Open your layout.html page.  Add the campusmap.gif image below the table and resize it (if 
needed) to be about 600 x 300 pixels. 

5b. Click once on the image to highlight it.  Then take a look at the Properties window for the Map 
options – in the lower left.  (If necessary, click on the downward pointing triangle arrow in the 
lower right corner.  This will expose the imagemap options that you need to use.)  Click on the 
“Oval Hotspot Tool”.   

5c. The cursor becomes a small crosshair icon.  Use this to drag a quarter-sized  (25¢) circle around the 
bell tower in the image.  If you need to adjust the size or position of the oval, return to the 
Properties window and click on the “Pointer Hotspot Tool” (the one with the black arrow on it).  
You can use this to move the hotspot or reshape it. 



 

5d. With the hotspot selected (bright blue), the Properties window will show all the hotspot properties.  
One of these hotspot properties is a link.  In the “Link” box, remove the “#” and enter 
http://www.furman.edu  

5e. Use the same basic procedure to draw a 1” rectangular hotspot around the Plyler Hall/Riley Hall 
area, and use the URL http://www.furman.edu/riley 

5f. Save and preview the page.  Note that the hotspots are invisible, but they do what you expect when 
you click on them. 

Other hotspot shapes are available as well.  And remember that you can always reshape and move 
existing hotspots if you like. 

Image rollovers 

Many buttons on web pages “react” to your mouse movement – if you ‘mouse over’ the image, it 
changes.  This is called an image rollover, because the image changes when the mouse “rolls over” it.  
Let’s try it out with a silly little example. 

5g. Go to our class web site and find the class roster images.  Copy your own picture and one other 
image to your Web site images folder.  Rename files if needed. 

5h. Open the layout.html page and remove the original 'Homer' image from the upper-right of the table.  
Position the cursor in this table cell.  Choose Insert>Image Objects>Rollover Image.   

5i. You’ll be asked for three important pieces of information.  First, name the image something like 
“Classpics”.  Giving the picture a name is important if you’re going to do something more 
complicated with it.  Click Browse to choose one of the images that you downloaded as your 
“Original Image” and one for your “Rollover Image”.  “Preload Images” should be checked, and 
there is no need to enter a "When clicked" URL for this example.  (Though you should note that you 
could...) 

5j. Click OK.  Save the page and preview it.  SOME browsers warn about a security issue – you can 
“Allow Blocked Content” if asked.  Move the mouse over the image, it should change. 

We don’t have to concern ourselves too much with how this works – yet.  But you should be aware that 
what’s being used here is Javascript.  Javascript is a programming language that you can use on Web 
pages to detect when certain events happen (like mouse rollovers, mouse clicks, etc.) and react to them 
by moving things around on the page, swapping pictures, and so on.  Take a look at the head section of 
the HTML source of your rollover page if you would like to see what the Javascript code looks like.  
We will discuss this more closely later in the term. 

6. Generalizing: Dreamweaver Behaviors  

As the preceding discussion suggests, Javascript is an extremely powerful tool.  It is made even more 
powerful by the fact that Dreamweaver generates it for us!  That’s what we’ll explore next – 
Dreamweaver Behaviors.  

A behavior basically involves an event that causes some action. 

This is the basic idea of Behaviors in a nutshell: Anything that you can put on a Web page – text, 
images, tables, table cells, links, etc. – can be given a name.  Once you name something, you can refer 
to it by that name.  Furthermore, all of these Web page objects have properties associated with them.  
For instance, images have a source (where the image is stored).  Table cells have a background color.  A 
section of text has a font, color, style, etc.   

If you can refer to something by name, you can define an action that changes some of its properties 
when the viewer does some event (mouse click, etc).  For example, you can: 



 

 make the source of an image change when the mouse rolls over it  (an image rollover) 
 change the background color of a table cell when a certain button is clicked   
 change the font and color of some text when a key is pressed.   

Each of these is an example of a Behavior – an event/action pair that you define. 

Behaviors are a bit complicated at first, but once you “get it” you’ll be able to do incredible things on 
your Web pages.  Take your time on this section!  And ask lots of questions.  We’ll just do a couple of 
interesting tasks, but what I hope you get out of it is an appreciation for how many different types of 
behaviors could be defined. 

Explicit Rollovers Using Behaviors 

To get started with a simple example, let’s create another rollover image manually, NOT using the 
Dreamweaver Rollover Image feature.  You can use the same two images that you used before, or you 
can choose two different ones. 

6a. Create a new page in Dreamweaver and save it as temp.html.  Insert one of your images.  Do not 
use Insert>Image Objects>Rollover Image --   Use Insert>Image instead. 

6b. Click once on the image to highlight it.  Then go to the Properties window and look in the lower-left 
for a text box next to the thumbnail copy of your image --  this is for the image name.  Give this the 
name pic1 . 

6c. Next, click on the Tag Inspector tab (upper-right of your screen – if it isn't there, use the menu 
Window>>Tag Inspector to display it).  To define a new behavior for this image, select the 

Behavior tab and click once on the + button.  You’ll see a list of possible behaviors.  Choose “Swap 
Image”.   

6d. The image that you just named should be highlighted in the “Images” box.  If not, highlight it.  Then 
click Browse to select the image that will replace this one.   

6e. Make sure that “Preload Images” and “Restore Image onMouseOut” are both checked.  Then click 
OK.   

You’ve just defined a behavior for your image!  Two of them, to be precise.  Look in the Behavior 
window.  You’ll see that two Event/Action pairs are listed alphabetically.  Here’s what they mean: 

 onMouseOver -When the mouse goes over the image, something happens: Here, a swap 
image action will occur; 

 onMouseOut - When the mouse leaves the image, something happens: Here, a restore 
action (Swap Image Restore) will occur, putting the original picture back. 

6f. Save the page and preview it.  Move the mouse over your new image. 

“Big deal!” you might be saying.  “I already knew how to do a rollover!”  True, but now you see how to 
do it using behaviors.  For a more challenging example, let’s try this... 

Behaviors involving layers 
A more recent addition to the HTML definition is the idea of layers – or the technical name: Absolute 
Position Divisions (AP Div for short)  These are basically smaller Web pages that can lie on top of a 
normal Web page.  What makes layers interesting is that they can be hidden or made visible as desired.  
(“Visibility” is one of their properties.)  This leads to some interesting possibilities.  This example will 
show or hide a layer as we move our mouse over the campus map. 

6g. Return to the layout.html page.  Use the menu  Insert>>Layout Objects>>AP Div to add a new 
layer 



 

Place and resize the layer to make it a 2-inch rectangle to the left of the Bell Tower hotspot that you 
created before. Position the layer so that the hotspot and the layer don’t overlap!  Once drawn, a 
layer can be moved by dragging the white box in the upper left.  Resize a layer with the block 
‘handles’ on the sides. 

6h. A layer is basically a mini-Web page, in which you can put anything that you’d put into a regular 
Web page.  Give the layer the name “Welcome” by typing it in the “name” box of the Properties 
window -- replacing the word "apDiv1". 

6i. Position the cursor inside this layer and type “Welcome to Furman University!”  Make the text h2, 
light blue. 

Finally, make the layer hidden by choosing “Hidden” in the “Vis” (visibility) box. 

Dreamweaver sometimes creates a small yellow “marker” (with a “C” in it) that corresponds to the 
layer – this marker will NOT display on the final page, but can be very useful in selecting the a 
hidden layer  – this is controlled by changing Preferences – Anchor points for AP Elements 

6j. Now we get down to the business of defining a new behavior.  First, click once on the Bell Tower 
hotspot to highlight it.  (This is important!  You’re defining a behavior for the hotspot, not the layer.  
If the layer is highlighted for these next steps it won’t work.)  Next, click on the Behaviors "+" sign 
to bring up the list of behaviors. 

6k. Choose “Show-Hide Elements”.  The window that comes up should have the div “Welcome” listed, 
and it should be highlighted.  If not, click on it to highlight it. 

6l. Click the Show button to indicate that the behavior you are defining will show the layer, rather than 
hide it.  Click OK.   

6m.Look at the Behaviors window.  (Notice that “onMouseOver” was automatically chosen as the event 
for your behavior.  That happens to be what you want this time, but realize that “onMouseOver” is 
the default).  The new behavior is saying this: “When the mouse moves over the Bell Tower 
hotspot, show the ‘Welcome’ layer.”  

6n. Next you have to specify another behavior to activate what happens when the mouse leaves the 
hotspot.  Reselect the hotspot and then click the '+' button again.  Pick “Show-Hide Layers” again.  
Highlight the “Welcome” layer again.  But this time click the Hide button.  Then click OK. 

6o Select the hotspot again.  Notice that “onMouseOver” is the default event for this new behavior 
(listed second) but that’s not what you want.  You actually want “onMouseOut”, so you will have to 
specify that.  Click the second "OnMouseOver" and click the downward pointing triangle arrow to 
show a list of options.  Choose “onMouseOut” and you are done. 

6p Save the page and preview it.  As you move the mouse over the Bell Tower, your layer should show 
as the mouse enters and hide as it leaves the hotspot area. 

 

This has been a long lab activity, and you’re probably tired of thinking about Web pages 
and Dreamweaver right now.  But when you have a quiet moment, give some thought to 
the possibilities behind this whole "Behaviors" idea.  You can apply a wide range of 
interesting behaviors to just about anything on a Web page.  Be creative! 

 

 

 



 

Concepts Learned: 

 Using tables to format web pages 
 CSS & Stylesheets 

 Image maps 
 Layers 
 Dreamweaver behaviors (rollover, 

show/hide layers, et al) 

What you should have created: 

 New files: calendar.html, layout.html, a css file mystyle.css 

 layout.html should have a roll-over image and image map with working show/hide layer 
behavior and working link.  Also a link to your calendar page. 

index.html calendar.html layout.html 

 

 

 

 

 
     Colored bg & holiday; formatted properly 

 

What to do Next: Updating your Web Site – Due on-line Monday 
 

 Your index.html file should be updated with a link to the layout.html page 

 Update your web site by copying all new (layout.html, calendar.html) and 
modified (index.html) files to the server and confirm operation.  DON'T 
FORGET IMAGES AND OTHER RESOURCE FILES! 

 If your “next” button still does not work – fix it! 

 Confirm proper operation from outside Riley Hall 
NOTE: Get it on-line a.s.a.p. –Murphy’s Law punishes those who wait! 
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