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Problem Solving Using 
Excel 2007

LEARNING OUTCOMES

Describe how to create and sort a list using Excel.
Explain why you would use conditional formatting using Excel.
Describe the use of AutoFilter using Excel.
Explain how to use the Subtotal command using Excel.
Describe the use of a PivotTable using Excel.

1.
2.
3.
4.
5.

Introduction
If you routinely track large amounts of information, such as customer mailing lists, 
phone lists, product inventories, sales transactions, and so on, you can use the extensive 
list-management capabilities of Excel to make your job easier.

In this plug-in you will learn how to create a list in a workbook, sort the list based 
on one or more fi elds, locate important records by using fi lters, organize and analyze 
entries by using subtotals, and create summary information by using pivot tables and 
pivot charts. Th e lists that you create will be compatible with Microsoft Access 2007, and, 
if you are not already familiar with Access, the techniques that you learn here will give 
you a head start on learning several database commands and terms. Plug-In T6, “Basic 
Skills and Tools Using Access 2007,” will provide detail on many of the Access database 
commands and terms.

Th ere are fi ve areas in this plug-in:

Lists.

Conditional Formatting.

AutoFilter.

Subtotals.

PivotTables.

Lists
A list is a collection of rows and columns of consistently formatted data adhering to 
somewhat stricter rules than an ordinary worksheet. To build a list that works with all of 
Excel’s list-management commands, you need to follow a few guidelines.

1.
2.
3.
4.
5.

P L U G - I N

T3
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When you create a list, keep the following in mind:

Maintain a fi xed number of columns (or categories) of information; you can alter the 
number of rows as you add, delete, or rearrange records to keep your list up to date.

Use each column to hold the same type of information.

Don’t leave blank rows or columns in the list area; you can leave blank cells, if neces-
sary.

Make your list the only information in the worksheet so that Excel can more easily rec-
ognize the data as a list.

Maintain your data’s integrity by entering identical information consistently. For ex-
ample, don’t enter an expense category as Ad in one row, Adv in another, and Adver-
tising in a third if all belong to the same classifi cation.

To create a list in Excel, you would follow these steps:

Open a new workbook or a new sheet in an existing workbook.

Create a column heading for each fi eld in the list, format the headings in bold  type, 
and adjust their alignment.

Format the cells below the column headings for the data that you plan to use. Th is can 
include number formats (such as currency or date), alignment, or any other formats.

Add new records (your data) below the column headings, taking care to be consistent 
in your use of words and titles so that you can organize related records into groups 
later. Enter as many rows as you need, making sure that there are no empty rows in 
your list, not even between the column headings and the fi rst record. See Figure T3.1 
for a sample list.

SORTING ROWS AND COLUMNS

Once your records are organized into a list, you can use several commands on the Data 
menu to rearrange and analyze the data. Th e Sort command allows you to arrange the 
records in a diff erent order based on the values in one or more columns. You can sort 
records in ascending or descending order or in a custom order, such as by days of the 
week, months of the year, or job title.

■

■

■

■

■

1.
2.

3.

4.

Each row
represents a
record in
the list.

Each column represents a field 
containing one type of information. 

FIGURE T3.1 

An Excel List   
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To sort a list based on one column, follow these steps:

Select the SortData worksheet from the T3_ProblemSolving_Data.xls workbook that 
accompanies this textbook.

Click any cell  in the Sales Rep column; you want to use this column as the basis for 
sorting the list.

Click the Data tab.

Click the Ascending button to specify the order to sort by (A to Z, lowest to highest, 
earliest date to latest).

Your screen will look similar to Figure T3.2. 

SORTING MORE THAN ONE COLUMN

If you have records in your list that have identical entries in the column you are sorting, 
you can specify additional sorting criteria to further organize your list.

To sort a list based on two or three columns follow these steps:

Click any cell in the Sales Rep column.

Click the Data tab, and then click the Sort button.  Th e Sort  dialog box opens.

Click the Column list arrow, and then select the Sales Rep in the Sort by drop-down 
list. Click the Order list arrow and specify A to Z order for that column.

Click the Add Level button, then click Magazine in the Th en by drop-down list. Spec-
ify A to Z order for the second sort.  

Click the Add Level button, then click Sale for the sort. Specify Smallest to Largest 
order for the third sort. Th e Sort dialog box should look like Figure T3.3 when you are 
done.

Click OK to run the sort.

Figure T3.4 shows how the sort looks based on the options you selected above. 

1.

2.

3.
4.

1.
2.
3.

4.

5.

6.

FIGURE T3.2  

A Sorted List
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To use a custom sort order, follow these steps:

Click any cell  in your list.

Click the Home tab, then under the Editing group 
click Sort & Filter, and then click Custom Sort.

Under Column, in the Sort by drop-down box, select 
the Region fi eld.

Under Order, select Custom List.

In the Custom Lists dialog box, select West, North, 
South, East, as shown in Figure T3.6. 

Click OK to run the sort. Your list appears sorted with 
the custom criteria you specifi ed.

Creating Conditional 
Formatting

Excel gives you the ability to add conditional formatting—formatting that automatically 
adjusts depending on the contents of cells—to your worksheet. Th is means you can high-
light important trends in your data, such as the rise in a stock price, a missed milestone, 

or a sudden spurt in your college expenses, 
based on conditions you set in advance using 
the Conditional Formatting dialog box. With 
this feature, an out-of-the-ordinary number 
jumps out at anyone who routinely uses the 
worksheet.

For example, if a stock in a Gain/Loss col-
umn rises by more than 20 percent, you want 
to display numbers in bold type on a light 
blue background. In addition, if a stock in the 
Gain/Loss column falls by more than 20 per-
cent, you want to display the number in bold 
type on a solid red background. Th is is when 
you want to use conditional formatting.

To create such a conditional format, complete the following steps: 

 1. If the workbook T3_ProblemSolving_Data.xls is closed, open it.

 2. Select the worksheet ConditionalFormatting.

 3. Select the column Sale. (Note that each cell can maintain its own, unique condi-
tional formatting, so that you can set up several diff erent conditions.)

 4. Click the Home tab.

 5. In the Styles section, click the Conditional Formatting button, and then point to 
Highlight Cell Rules and click Between. . . . 

 6. In the fi rst text box, type the number 1000.

 7. In the second text box, type the number 1200.

 8. In the third text box, use the drop-down arrow to select Green Fill with Dark Green 
Text. Figure T3.7 displays the settings for this example.

 9. Click OK. If any numbers fall into the ranges you specifi ed, the formatting you speci-
fi ed will be applied.

10. Now you need to add another rule to supply a diff erent criteria. Click the Condi-
tional Formatting button, and then point to Highlight Cell Rules and click Greater 
Th an. . . . 

1.
2.

3.

4.
5.

6.

FIGURE T3.5 

Creating a Custom Sort 
Order

FIGURE T3.6 

Sort Options Dialog Box
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11. Type 1250 in the fi rst box and select Red Fill with Dark Red Text using the drop-
down arrow from the second box.

12. Click OK. 

13. If any numbers fall into the ranges you identifi ed, the formatting you specifi ed will be 
applied. Figure T3.8 shows the conditional formatting you entered for this example.

Using AutoFilter to Find Records
When you want to hide all the records (rows) in your list except those that meet certain 
criteria, you can use the AutoFilter command on the Filter submenu of the Data menu. 
Th e AutoFilter command places a drop-down list at the top of each column in your list 
(in the heading row). To display a particular group of records, select the criteria that you 
want in one or more of the drop-down lists. For example, to display the sales history for 
all employees that had $1,000 orders in January, you could select January  in the Month  
column drop-down list and $1,000  in the Sale  drop-down list.

To use the AutoFilter command to fi nd records, follow these steps:

If the workbook T3_ProblemSolving_Data.xls is closed, open it.

Select the worksheet AutoFilter.

Click any cell  in the list.

Click the Data tab and then click the Filter button in the Sort & Filter section.  Each 
column head now displays a list arrow.

Click the list arrow  next to the Region heading. A list box that contains fi lter options 
appears, as shown in Figure T3.9.

1.
2.
3.
4.

5.

FIGURE T3.7 

Conditional Formatting 
Dialog Box

FIGURE T3.8 

Conditional Formatting
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If a column in your list contains one or more blank cells, you will also see (Blanks) 
and (NonBlanks) options at the bottom of the list. Th e (Blanks)  option displays only the 
records containing an empty cell (blank fi eld) in the fi lter column, so that you can locate 
any missing items quickly. Th e (NonBlanks)  option displays the opposite—all records 
that have an entry—in the fi lter column.

Select only East to use for this fi lter (you will have to uncheck the other entries). Excel 
hides the entries that don’t match the criterion you specify and highlights the active 
fi lter arrow. Figure T3.10 shows the results of using East as the criterion in the Region 
column. 

You can use more than one fi lter arrow to further narrow your list, which is useful if 
your list is many records long. To continue working with AutoFilter but also redisplay 
all your records, click the list arrow  next to Region and check Show All. Excel displays 
all your records again. 

 To remove the AutoFilter drop-down lists, unselect the AutoFilter  command on the 
Filter  submenu.

6.

7.

8.

Filter button
from the Data tab.

AutoFilter
options for
the Region

column.

FIGURE T3.9 

AutoFilter Options

Filter button
from the Data tab.

Active filter
icon.

Rows that fit
the filter
criteria.

FIGURE T3.10 

AutoFilter Output 
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CREATING A CUSTOM AUTOFILTER

When you want to display a numeric range of data or customize a col-
umn fi lter in other ways, choose Custom Filter . . .  from the Number 
Filters  option to display the Custom AutoFilter  dialog box. Th e dia-
log box contains two relational list boxes and two value list boxes that 
you can use to build a custom range for the fi lter. For example, you 
could display all sales greater than $1,000 or all sales between $500 
and $800.

To create a custom AutoFilter, follow these steps:

Click any cell  in the list.

Click the Data tab and then click the Filter button. 

Click the list arrow next to the heading Sale and select Number Filters, then click on 
Custom Filter. . . . Th e Custom AutoFilter  dialog box opens.

Click the fi rst list box and select is greater than or equal to and then click the value 
list  box and select $500.

Click the And radio button to indicate that the records must meet both criteria, then 
specify is less than or equal to in the second list box and select $800 in the second 
value list box. Figure T3.11 shows the Custom AutoFilter dialog box with two range 
criteria specifi ed.

Click OK to apply the custom AutoFilter. Th e records selected by the fi lter are dis-
played in your worksheet.

Analyzing a List with the Subtotals Command
Th e Subtotals command in the Outline section  of the Data menu helps you organize and 
analyze a list by displaying records in groups and inserting summary information, such 
as subtotals, averages, maximum values, or minimum values. Th e Subtotals command 
can also display a grand total at the top or bottom of your list, letting you quickly add up 
columns of numbers. As a bonus, Subtotals displays your list in Outline view so that you 
can expand or shrink each section in the list simply by clicking.

To add subtotals to a list, follow these steps:

If the workbook T3_ProblemSolving_Data.xls is closed, open it.

Select the worksheet Subtotals.

Arrange the list so that the records for each group are located together. To do 
this, sort the list by Sales Rep.

Click the Data tab, then click the Subtotal button in the Outline section.  Excel 
opens the Subtotal  dialog box and selects the list.

In the At each change in: list box, choose Sales Rep. Each time this value 
changes, Excel inserts a row and computes a subtotal for the numeric fi elds in 
this group of records.

In the Use function: list box, choose Sum.

In the Add subtotal to: list box, choose Sale, which is the column to use in the 
subtotal calculation. Figure T3.12 shows the settings for this example.

Click OK to add the subtotals to the list. You will see a screen similar to the 
one in Figure T3.13, complete with subtotals, outlining, and a grand total.

1.
2.
3.

4.

5.

6.

1.
2.
3.

4.

5.

6.
7.

8.

FIGURE T3.11 

Custom AutoFilter

FIGURE T3.12 

Subtotal Settings
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When you use the Subtotals command in Excel to create outlines, you can examine 
diff erent parts of a list by clicking buttons in the left margin. Click the numbers at the top 
of the left margin to choose how many levels of data you want to see. Click the plus or 
minus button to expand or collapse specifi c subgroups of data.

You can choose the Subtotals command as often as necessary to modify your group-
ings or calculations. When you are fi nished using the Subtotals command, click Remove 
All in the Subtotal  dialog box.

PivotTables
A powerful built-in data-analysis feature in Excel is the PivotTable. A PivotTable ana-
lyzes, summarizes, and manipulates data in large lists, databases, worksheets, or other 
collections. It is called a PivotTable because fi elds can be moved within the table to cre-
ate diff erent types of summary lists, providing a “pivot.” PivotTables off er fl exible and 
intuitive analysis of data.

Although the data that appear in PivotTables look like any other worksheet data, the 
data in the data area of the PivotTable cannot be directly entered or changed. Th e Pivot-
Table is linked to the source data; the output in the cells of the table are read-only data. 
Th e formatting (number, alignment, font, etc.) can be changed as well as a variety of 
computational options such as SUM, AVERAGE, MIN, and MAX.

PIVOTTABLE  TERMINOLOGY

Some notable PivotTable terms are: 

Row fi eld—Row fi elds have a row orientation in a PivotTable report and are displayed 
as row labels. Th ese appear in the ROW area of a PivotTable report layout.

Column fi eld—Column fi elds have a column orientation in a PivotTable report and 
are displayed as column labels. Th ese appear in the COLUMN area of a PivotTable 
report layout.

■

■

Subtotal button
from the Data tab.

Total for
Rachel

Anderson.

FIGURE T3.13 

Subtotals, Outline, and 
Grand Total   
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Data fi eld—Data fi elds from a list or table contain summary data in a PivotTable, 
such as numeric data (e.g., statistics, sales amounts). Th ese are summarized in the 
DATA area of a PivotTable report layout.

Page fi eld—Page fi elds fi lter out the data for other items and display one page at a 
time in a PivotTable report.

BUILDING A PIVOTTABLE 

Th e PivotTable Wizard steps through the process of creating a PivotTable, allowing a vis-
ual breakdown of the data in the Excel list or database. When the wizard steps are com-
plete, a diagram, such as Figure T3.14, with the labels PAGE, COLUMN, ROW, and DATA 
appears. Th e next step is to drag the fi eld buttons onto the PivotTable grid. Th is step tells 
Excel about the data needed to be analyzed with a PivotTable.

Using the PivotTable Feature 

If the workbook T3_ProblemSolving_Data.xls is closed, open it.

Select the worksheet PivotTableData. Click any cell in the list. Now the active cell is 
within the list, and Excel knows to use the data in the Excel list to create a PivotTable.

Click the Insert tab, then click the PivotTable button in the Tables group,  and click 
on PivotTable.

Th e Create PivotTable  dialog box opens. In the Select a table or range  box, make 
sure you see $A$1:$E$97.  

Click OK. Your spreadsheet will now look like Figure T3.14. 

Using the PivotTable Field List, drag the Month button to the PAGE area. Th e page 
fi eld operates like the row and column fi elds but provides a third dimension to the 
data. It allows another variable to be added to the PivotTable without necessarily 
viewing all its values at the same time.

Drag the Region button to the COLUMN area. Th e column fi eld is another variable 
used for comparison.

Drag the Magazine button to the ROW area. A row fi eld in a PivotTable is a variable 
that takes on diff erent values.

Drag the Sale button to the DATA area. Th e data fi eld is the variable that the Pivot 
Table summarizes. Your PivotTable should now look like Figure T3.15.

■

■

1.
2.

3.

4.

5.
6.

7.

8.

9.

PAGE
Fields

COLUMN 
Fields

ROW 
Fields

Field List

DATA ITEMS

FIGURE T3.14 

The PivotTable, PivotTable 
Toolbar, and PivotTable 
Field List 
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MODIFYING A PIVOTTABLE VIEW

After a PivotTable is built, modifi cations can be done at any time. For example, examin-
ing the sales for a particular region would mean that the Region fi eld would need to be 
changed. Use the drop-down list to the right of the fi eld name. Select a region and click 
OK. Th e grand total dollar amounts by region are at the bottom of each item, which have 
been recalculated according to the selected region (or regions).

Th is report can be used in various ways to analyze the data. For instance, click the 
Clear button on the PivotTable ribbon, click Clear All, then arrange the fi elds like this:

Magazine in the PAGE area.

Month in the COLUMN area.

Sales Rep in the ROW area. 

Sale in the DATA area.

Th e completed PivotTable dialog box should look like the one in Figure T3.16. Th e 
PivotTable now illustrates the sales by month for each salesperson, along with the total 
amount for the sales for each sales representative.

1.
2.
3.
4.

FIGURE T3.15 

The PivotTable with Data, 
PivotTable Toolbar, and 
PivotTable Field List      

FIGURE T3.16 

Rearranged Data
in the PivotTable
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BUILDING A PIVOTCHART

A PivotChart  is a column chart (by default) that is based on the data in a PivotTable. Th e 
chart type can be changed if desired. To build a PivotChart:

Click the PivotChart button  in the Tools section of the PivotTable ribbon. 

Th e Insert Chart  dialog box appears. Select the Stacked  Column chart and click OK.

Th e chart appears in your PivotTable worksheet. Click the Move Chart button on the 
PivotTable ribbon (on the Design tab, in the Location group) and select New sheet  
from the Move Chart  dialog box. 

Th e PivotChart should look like Figure T3.17.

Note: Whatever changes are selected on the PivotChart are also made to the PivotTa-
ble, as the two features are linked dynamically.

1.
2.
3.

4.

FIGURE T3.17 

PivotChart  
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If you routinely track large amounts of information, you can use several Excel tools for prob-
lem solving. A list is a table of data stored in a worksheet, organized into columns of fields 
and rows of records. Excel gives you the ability to add conditional formatting—formatting 

that automatically adjusts depending on the contents of cells—to your worksheet. The AutoFil-
ter command places a drop-down list at the top of each column in your list (in the heading row). 
The Subtotals command on the Data menu helps you organize and analyze a list by displaying 
records in groups and inserting summary information, such as subtotals, averages, maximum 
values, or minimum values. A PivotTable analyzes, summarizes, and manipulates data in large 
lists, databases, worksheets, or other collections.

M A K I N G  B U S I N E S S  D E C I S I O N S*

*

1. Production Errors
Established in 2002, t-shirts.com has rapidly become the place to find, order, and save on 
T-shirts. One huge selling factor is that the company manufactures its own T-shirts. How-
ever, the quality manager for the production plant, Kasey Harnish, has noticed an unac-
ceptable number of defective T-shirts being produced. You have been hired to assist Kasey 
in understanding where the problems are concentrated. He suggests using a PivotTable to 
perform an analysis and has provided you with a data file, T3_TshirtProduction_Data.xls. 
The following is a brief definition of the information within the data file:

Batch: A unique number that identifies each batch or group of products produced.
Product: A unique number that identifies each product.
Machine: A unique number that identifies each machine on which products are
produced.
Employee: A unique number that identifies each employee producing products.
Batch Size: The number of products produced in a given batch.
Num Defect: The number of defective products produced  in a given batch.

2. Coffee Trends
College chums Hannah Baltzan and Tyler Phillips are working on opening a third espresso 
drive-through stand in Highlands Ranch, Colorado, called Brewed Awakening. Their origi-
nal drive-through stand, Jitters, and their second espresso stand, Bean Scene, have done 
well in their current locations in Englewood, Colorado, five miles away. Since Hannah and 
Tyler want to start with low overhead, they need assistance analyzing the data from the 
past year on the different types of coffee and amounts that they sold from both stands. 
Hannah and Tyler would like a recommendation of the four top sellers to start offering 
when Brewed Awakening opens. They have provided you with the data file T3_JittersCof-
fee_Data.xls for you to perform the analysis that will support your recommendation.

3. Filtering SecureIT Data
SecureIT, Inc., is a small computer security contractor that provides computer security 
analysis, design, and software implementation for commercial clients. Almost all of Se-
cureIT work requires access to classified material or confidential company documents. 

A.
B.
C.

D.
E.
F.

P L U G - I N  S U M M A R Y

haa10778_plugint03.indd   14haa10778_plugint03.indd   14 7/20/07   12:38:06 PM7/20/07   12:38:06 PM



Plug-In T3 Problem Solving Using Excel 2007 * T3-15

Consequently, all of the security personnel have clearances of either Secret or Top Se-
cret. Some have even higher clearances for work that involves so-called black box security 
work.

While most of the personnel information for SecureIT resides in database systems, a 
basic employee worksheet is maintained for quick calculations and ad hoc report genera-
tion. Because SecureIT is a small company, it can take advantage of Excel’s excellent list 
management facilities to satisfy many of its personnel information management needs. You 
have been provided with a sample worksheet, T3_Employee_Data.xls, to assist SecureIT 
with producing several worksheet summaries. Here is what is needed:

One worksheet that is sorted by last name and hire data.
One worksheet that uses a custom sort by department in this order: Marketing, Human 
Resources, Management, and Engineering.
One worksheet that uses a filter to display only those employees in the Engineering 
department with a clearance of Top Secret (TS).
One worksheet that uses a custom filter to display only those employees born between 
1960 and 1969 (inclusive).
One worksheet that totals the salaries by department and the grand total of all depart-
ment salaries. This worksheet should be sorted by department name first.

4. Filtering RedRocks Consulting Contributions
RedRocks Consulting is a large computer consulting firm in Denver, Colorado. Don Mc-
Cubbrey, the CEO and founder of the firm, is well-known for his philanthropic efforts. He 
believes that many of his employees also contribute to nonprofit organizations and wants 
to reward them for their efforts while encouraging others to contribute to charities. He 
started a program in which RedRocks Consulting matches 50 percent of each donation an 
employee makes to the charity of his or her choice. The only guidelines are that the char-
ity must be a nonprofit organization and the firm’s donation per employee may not exceed 
$500 a year.

Don has started an Excel file, T3_RedRocks_Data.xls, to record the firm’s donations. 
Included in this file are the dates the request for a donation was submitted, the employee’s 
name and ID number, the name of the charity, the dollar amount contributed by the firm, 
and the date the contribution was sent. Don wants you to help him create several work-
sheets with the following criteria:

One worksheet that sorts the list alphabetically by organization and then by employee’s 
last name.
One worksheet that totals the contribution made per employee for the month of 
December. 
One worksheet that sorts the list by donation value by lowest amount to highest 
amount.

1.
2.

3.

4.

5.

1.

2.

3.
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